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Computer interface
The MegaBee writing tablet is able to interface with a personal computer which has
Bluetooth communication capability.
The PC software is on the CD provided as part of the MegaBee product, but it may
also be downloaded free of charge from www.e2l.uk.com/manuals/
The purpose of linking to a computer is to provide three distinct enhancements to
the MegaBee’s normal operation:
1)

DISPLAY

MegaBee can be use the display and storage facilities of the PC to provide large
screen for viewing or projection, and for storing any text which may have been
written.
2)

VOCABULARY

MegaBee can upload predefined messages which can act as a ‘shortcut’ to quicker
communication. This is similar to speed dialing on telephones - a letter plus a single
number gives a phrase.
3)

PICTURES

MegaBee can be used in a picture display mode where the normal letters are
replaced by pictures selected by the user. These are provided as peel-off labels
which can be printed at home.

Installing the software
On the CD provided select the file named ‘setup.exe’. This will start the installation
wizard and install the software in a program file called /MegaBee/
A MegaBee icon will be installed on your desktop for easy access.
There are numerous different Bluetooth drivers for modern PCs and these may
react in certain undefined ways. The supplied software has been tested on many
systems but cannot guarantee full compatibility with all Bluetooth enabled Pcs.
Should there be any problems then a specific external Bluetooth dongle can be
supplied which performs correctly. Please ask your supplier for details.

Bluetooth COM port
The first task is to identify the COM port address. This is the virtual port which is
being used by MegaBee when the Bluetooth link is being used. It is quite simple to
do this.
On your PC you will have a program called ‘My Bluetooth Places’, or ‘Bluetooth
Settings’, or perhaps a Bluetooth icon in the task bar at the bottom of the screen.
Click on this and you should get a screen similar to:

OR

This displays any current devices that may have been previously connected.
What we need to do is search for any new Bluetooth devices. To do this switch on
the MegaBee and press the function key.
Using the UP and DOWN Grey buttons, scroll through the menu until ‘TIMEOUT’ is
reached. Select this option and set the timeout at 5 minutes. (This is simply to avoid
the MegaBee powering down, whilst you are trying to set up the link).

Next, scroll through the MegaBee function menu until you reach ‘BLUETOOTH’.
Select this option and choose ‘ACTIVE’. Press the Grey ENTER button and then go
back to normal operation (Press the black function button).

On the PC double-click on ‘New Connection’ or ‘View devices in range’. This will
make the PC search for any Bluetooth devices in range and then set-up a
communication link with them.
After a few seconds the PC will have found the MegaBee and you should see a
report, something like:

OR

In either case the program should find your device and it will have an identity
something like “MegaBee 01234” corresponding to the serial number. (If you are
using MegaBee in an area where there are several other users, this is how you
know which is yours).
Note:
On some systems you may find a device called “Free2Move” the first time you use
the link - this is your MegaBee but the computer hasn’t yet established a full link. If
your system works in this way you have to “Discover Services” from your PC
program (normally right click and select, or from the “Services” menu).
In the left-hand example above this screen tells you that MegaBee, serial number
01006, (for example), has been found in range. If you select the MegaBee by
clicking on it and then click on ‘next’ the wizard will set-up the com port.
In the right-hand example, MegaBee, serial number 01005 has been located. In this
system you need to right click on the MegaBee image, and select ‘connect’.
Note:
If you have a MegaBee version 3.5 or earlier then you do not need a ‘passkey’; if
this is asked for by the installation wizard then click on the ‘skip’ button. For
MegaBee versions 3.6 onwards the passkey you require is ‘0000’.
When complete, the wizard will tell you the number of the COM port it has assigned.
Examples of both systems are shown on the next page.

In this particular case the COM port
the PC has assigned is ‘COM50’.

With this system right click and select
‘status’. The COM port the PC has
assigned is ‘COM8’.

Make a note of this number as you will need it later.

MegaBee Software Utilities
To start the software suite click on the MegaBee icon or select ‘MegaBee’
from the program list.
A small selection screen will appear from which you must choose ‘Display’,
‘Vocabulary’, or ‘Pictures’.

Select one of the three tasks, and you will then enter the main programs.

The DISPLAY program
The DISPLAY program allows any text written on the MegaBee to be downloaded
and displayed, either as character by character, or as a memory transfer.
However the first operation is to connect to the MegaBee. Ensure the MegaBee is
‘ON’ and Bluetooth is ‘ACTIVE’.

Select ‘Display’ from the starting screen shown on the previous page. This will
provide the basic display screen.
To use this facility we must connect the computer to the MegaBee. This is done by
clicking on the connect menu. The following
pop-up screen appears:

Ensure this is the COM port
as discussed previously
Press to connect. This screen
will disappear and the main
display is ready to use.
On the MegaBee unit:
For character by character transfer, simply use the unit as normal and any character
typed will be displayed simultaneously on the computer screen in a large format.

If you want to save everything that has already been written in then the contents of
MegaBee can be sent to the display program. For this feature enter the function
menu and select ‘DOWNLOAD’.

Pressing UP or DOWN will send all the whole contents of the MegaBee buffer will
be sent to the computer and displayed on the screen. A ‘DOWNLOAD COMPLETE’
message is provided. This text can then be saved in a file on the computer if
required.

The ‘File’ menu allows the user to save any of the text that has been written on the
MegaBee. Select ‘Save’ from the drop-down list of options and then type in a name
to save the file under.

The VOCABULARY program
The VOCABULARY program is a powerful way of producing phrases and assigning
them to special key sequences. It allows a maximum of 260 special phrases, all
coded as a letter followed by a number; ‘H2’ for example, might mean ‘HOT’.
Individual vocabularies can be stored for a variety of different people, and they can
be customized as more frequent words become more important at certain stages of
life. Vocabularies can be stored on the PC and uploaded at will, taking only a few
seconds to fully load.
However the first operation is to connect to MegaBee. On the MegaBee itself go to
the vocabulary menu and ensure it is set to ‘ACTIVE’.

Stay in the ‘ACTIVE’ mode (Do NOT press the enter key).
Now the computer needs to connect with your MegaBee.
This is done by clicking on the
connect menu. The following
pop-up screen appears:

Ensure this is the COM port
as discussed previously
Press to connect. This screen
will disappear and the main
display is ready to use.

A new vocabulary can now be loaded using the ’Open’ option in the file menu.
Similarly new vocabularies can be saved for later use, or use in particular situations,
or for several people, by using the ‘Save’ option.
Alternatively, new words can be added directly from the screen. For example:
To make ‘T0’ shorthand for ‘I am thirsty’, select the letter ‘T’ button, and in the white
box next to ‘T0’ type in ‘I am thirsty’. This can now be sent to the MegaBee by
pressing the upload icon. Each phrase can be up to 20 letters long.

When the ‘VOCABULARY’ function is ACTIVE on the MegaBee, click on the upload
button on the computer screen.
On the MegaBee unit:
Select FUNCTION/VOCABULARY/ACTIVE. The screen will indicate upload in
progress and completed. Press the function button to exit.

The PICTURES program
The PICTURES program allows user defined symbols or pictures to be used instead
of text, for people with literacy difficulties. It allows a maximum of 36 special phrases
to be associated with the pictures.
The pictures themselves, are prepared by using a template and then printing them
out at home. This means that any image can be used such as photographs,
drawings, cartoons or approved symbols; the choice is entirely up to the user. To
prepare the stick-on labels refer to the Appendix.
This section deals with transferring the phrases associated with the pictures into the
MegaBee. It is very similar to the VOCABULARY function described in the previous
section.
The first operation is to connect to MegaBee. On the MegaBee itself go to the
vocabulary menu and ensure it is set to ‘ACTIVE’.

Stay in the ‘ACTIVE’ mode (Do NOT press the enter key).
Now the computer needs to connect with your MegaBee.
This is done by clicking on the
connect menu. The following
pop-up screen appears:

Ensure this is the COM port
you recorded when setting up
Bluetooth
Press to connect. This screen will disappear and the main display is ready to use.

A new set of phrases can now be loaded using the’ Load’ option in
the file menu. Similarly new vocabularies can be saved for later
use, or use in particular situations, or for several people, by using
the ‘Save’ option.
Alternatively, new words can be added directly from the screen.
For example, let us assume we have made some labels using the
templates (See the Appendix). You will have two sheets of labels; one for either side
of MegaBee. Referring to the side with the buttons, for the blue block we might
have:

‘Button’ side

Blue block

Here we have six symbols for: mealtime, help me to, bathe, toilet, wash, bedtime.
What we now need to do is type these phrases into the relevant locations on the
computer screen. Each phrase can be up to 20 letters long.

When all the relevant phrases have been typed in then save them from the ‘File’
menu.
To complete the operation, these phrases need to be transferred to MegaBee.
Ensure the ‘VOCABULARY’ function is ACTIVE on the MegaBee unit, and that the
Bluetooth link is connected.

Click on the upload button on the computer screen, and the phrases will be sent
over the link.
On the MegaBee unit:
The screen will indicate upload in progress and completed.
Ensure that the ‘MODE’ function is set to ‘Picture display mode’.

Press the function button to exit.

Appendix 1 - Printing labels
To use the PICTURES facility you must prepare and print off your own self-adhesive
labels. To achieve this packs of pre-cut labels are available from your supplier which
allow accurate printing and easy use. They come in pack of ten pre-cut sheets
suitable for printing on (Part Number PN-369-036)
Any symbols, pictures, cartoons, or drawings can be used. A good source of
symbols which have an open source license (you can use them for free) is
http://straight-street.com/help.php.
The layout of the pictures is assisted by using templates available on your CD.
These are provided for various commercially available programs such as Microsoft
Word, CorelDRAW, OpenOffice.org Draw, etc. Examples are given for each
program in this appendix.
Each time you make a set of labels, two pages have to be printed; one for the
reader (button side), one for the writer. These two pages are different. The
templates are clearly marked as to which side you are working on by outline
drawings of the MegaBee:

Page 1
(Writer)

Page2
(Reader)(Buttons)

Appendix 1 - Printing labels (...)
Strict placement of the pictures has to be observed. This is not as complicated as it
may sound and is easily illustrated.
Using the Blue block for example. On Page 1 (Writer side) we could fill out the block
like this:

We know this is the writer’s
side because the small icon
has no buttons and the blue
block is in the top left hand
corner.
On Page 2 (Reader side) we
need to insert the same
images, but in reverse order
on the rows

We know this is the reader’s
side because the small icon
has buttons and the blue
block is in the top right hand
corner.

Once both sheets are complete they can be printed off on any reasonable quality
colour printer.

Appendix 1 - Printing labels (...)
When you have printed your labels, peel them off and place them over the
corresponding text label.

Ensure that both the colour of the block, and the colour of the smaller frames on the
label correspond to the existing label and colour of the letters on MegaBee.

Appendix 2 - Microsoft word template
Various templates are provided for preparing your labels. This section is for people
who use Microsoft Word.
A template is provided on the MegaBee CD called MegaBeeSymbolTemplate.dot. If
you open this file and then ‘Save As’ a template then Word will then include it in its
list of templates.
To produce your labels in Word:
From the File Menu choose ‘New’, then select ‘General Templates’ from beneath
the ‘New From Template’ list on the right hand side of your screen. The Template
pop-up will appear.

Select MegaBeeSymbolTemplate.dot and press OK.
A two page document will be presented with dull blank labels:

Appendix 2 - Microsoft word template (...)
To add pictures or symbols go to the Insert menu and select ‘Picture’. Then select
your source of pictures - usually ‘From File’ or ‘Clip Art’.

In this example we will use a pair of boots. The selected image will appear on top of
the labels:

Appendix 2 - Microsoft word template (...)
Obviously this image is too large so we need to resize it by pointing to one of the
black squares in the corner of the image, press and hold the left mouse button, and
dragging the corner so that we have a smaller image.

Now right click on the image and select ‘Properties’, and then select the ‘Layout’
tab.

Select ‘In Front of Text’ and click OK.

Appendix 2 - Microsoft word template (...)
Now the image can be dragged and dropped (click and hold on the image and drag
it with the mouse) to your chosen label location.

The image can be resized using the corner guides, and finally positioned into place
(in this example, the white square in the blue block).

Appendix 2 - Microsoft word template (...)
We now have to copy the image to the corresponding position on page #2. In this
example the white square in the blue block. To do this, select the image (click on it
with the mouse) then go to the ‘Edit’ Menu and select ‘Copy’ (Shortcut is Control-C)

Scroll down to page 2 and paste the image from the ‘Edit’ menu (Shortcut is
Control-V)

Appendix 2 - Microsoft word template (...)
Drag and drop the image into the white square in the blue block:

Repeat this process for all your pictures, and then save as a document:

Printing this document will produce two sheets of self adhesive labels. The meaning
of the symbols should be transferred to MegaBee as detailed in the ‘Pictures’
section earlier in this manual.

Appendix 3 - CorelDRAW template
Various templates are provided for preparing your labels. This section is for people
who use CorelDRAW Graphics Suite.
A template is provided on the MegaBee CD called MegaBeeSymbolTemplate.cdt.
To produce your labels in CorelDRAW:
From the File Menu choose ‘New from Template’, then select the ‘Browse’ Tab,
locate and select the file MegaBeeSymbolTemplate.cdt and click OK.

A two page document will be presented with blank labels:

Appendix 3 - CorelDRAW template (...)
To add pictures or symbols go to the File menu and select ‘Import’.

In this example we will use a symbol for washing clothes.

Appendix 3 - CorelDRAW template (...)
Place the picture in the required frame using the ‘click and drag’ facility. In this
example we will put the symbol in the red square on the blue block.

The symbol can be adjusted in size and position using the corner markers:

Appendix 3 - CorelDRAW template (...)
We now have to copy the image to the corresponding position on page #2. In this
example the red square in the blue block. To do this, select the image (click on it
with the mouse) then go to the ‘Edit’ Menu and select ‘Copy’ (Shortcut is Control-C)

Select Page 2 and paste the image from the ‘Edit’ menu (Shortcut is Control-V)

We now need to move the image to the red square in the blue block.

Appendix 3 - CorelDRAW template (...)
Drag and drop the image into the red square in the blue block:

Repeat this process for all your pictures, and then save as a document:

Printing this document will produce two sheets of self adhesive labels. The meaning
of the symbols should be transferred to MegaBee as detailed in the ‘Pictures’
section earlier in this manual.

Appendix 4 - OpenOffice.org Draw template
Various templates are provided for preparing your labels. This section is for people
who use OpenOffice.org program suite and utilises the Draw program.
A template is provided on the MegaBee CD called MegaBeeSymbolTemplate.otg.
To produce your labels in OpenOffice.org:
Select the Drawing Feature from the opening screen.

From the File Menu choose ‘New’, then
‘Templates and Documents’.

Locate and select the file
MegaBeeSymbolTemplate.otg and click OK.

Appendix 4 - OpenOffice.org Draw (...)

A two slide document will be
presented with blank labels:

Make sure the ‘Pictures’ tab is
selected. (If it is not then no
alterations will be possible)

To add pictures or symbols go to
the Insert menu and select
‘Picture’, and then ‘From File’.

Appendix 4 - OpenOffice.org Draw (...)
Select the required pictures from the pop-up screen and press OK.
In this example we will use a symbol for ‘dinner time’.

The selected image will appear on top of the labels.

Appendix 4 - OpenOffice.org Draw (...)
Resize the image by dragging the
corner guides and position it in the
required location. In this example we
are using the white square in the blue
block.
We now have to copy the image to
the corresponding position on slide
#2. In this example the white square
in the blue block.
To do this, select the image (click on it with the mouse) then go to the
‘Edit’ Menu and select ‘Copy’ (Shortcut is Control-C).
Now click on slide 2, in the pages bar on the left hand side of the screen.

Paste the image from the ‘Edit’ menu
(Shortcut is Control-V).

We now need to move the image to
the white square in the blue block.

Appendix 4 - OpenOffice.org Draw (...)
Repeat this process for all your pictures, and then save as a document:

Printing this document will produce two sheets of self adhesive labels. The meaning
of the symbols should be transferred to MegaBee as detailed in the ‘Pictures’
section earlier in this manual.

